86 lines
3.3 KiB
Diff
Executable File
86 lines
3.3 KiB
Diff
Executable File
We cross compile python. This patch uses tools from host/native
|
|
python instead of in-tree tools
|
|
|
|
-Khem
|
|
|
|
Upstream-Status: Inappropriate[Configuration Specific]
|
|
|
|
---
|
|
Makefile.pre.in | 25 +++++++++++++------------
|
|
1 file changed, 13 insertions(+), 12 deletions(-)
|
|
|
|
Index: Python-3.5.2/Makefile.pre.in
|
|
===================================================================
|
|
--- Python-3.5.2.orig/Makefile.pre.in
|
|
+++ Python-3.5.2/Makefile.pre.in
|
|
@@ -220,6 +220,7 @@ LIBOBJS= @LIBOBJS@
|
|
|
|
PYTHON= python$(EXE)
|
|
BUILDPYTHON= python$(BUILDEXE)
|
|
+HOSTPYTHON= $(BUILDPYTHON)
|
|
|
|
cross_compiling=@cross_compiling@
|
|
PYTHON_FOR_BUILD=@PYTHON_FOR_BUILD@
|
|
@@ -279,6 +280,7 @@ LIBFFI_INCLUDEDIR= @LIBFFI_INCLUDEDIR@
|
|
##########################################################################
|
|
# Parser
|
|
PGEN= Parser/pgen$(EXE)
|
|
+HOSTPGEN= $(PGEN)$(EXE)
|
|
|
|
PSRCS= \
|
|
Parser/acceler.c \
|
|
@@ -509,7 +511,7 @@ build_all_generate_profile:
|
|
|
|
run_profile_task:
|
|
: # FIXME: can't run for a cross build
|
|
- $(LLVM_PROF_FILE) $(RUNSHARED) ./$(BUILDPYTHON) $(PROFILE_TASK) || true
|
|
+ $(LLVM_PROF_FILE) $(RUNSHARED) $(HOSTPYTHON) $(PROFILE_TASK) || true
|
|
|
|
build_all_merge_profile:
|
|
$(LLVM_PROF_MERGER)
|
|
@@ -792,7 +794,7 @@ $(GRAMMAR_H): $(GRAMMAR_INPUT) $(PGEN)
|
|
@$(MKDIR_P) Include
|
|
# Avoid copying the file onto itself for an in-tree build
|
|
if test "$(cross_compiling)" != "yes"; then \
|
|
- $(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C); \
|
|
+ $(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C); \
|
|
else \
|
|
cp $(srcdir)/Include/graminit.h $(GRAMMAR_H).tmp; \
|
|
mv $(GRAMMAR_H).tmp $(GRAMMAR_H); \
|
|
@@ -990,7 +992,7 @@ $(LIBRARY_OBJS) $(MODOBJS) Programs/pyth
|
|
######################################################################
|
|
|
|
TESTOPTS= $(EXTRATESTOPTS)
|
|
-TESTPYTHON= $(RUNSHARED) ./$(BUILDPYTHON) $(TESTPYTHONOPTS)
|
|
+TESTPYTHON= $(RUNSHARED) $(HOSTPYTHON) $(TESTPYTHONOPTS)
|
|
TESTRUNNER= $(TESTPYTHON) $(srcdir)/Tools/scripts/run_tests.py
|
|
TESTTIMEOUT= 3600
|
|
|
|
@@ -1481,7 +1483,7 @@ frameworkinstallstructure: $(LDLIBRARY)
|
|
fi; \
|
|
done
|
|
$(LN) -fsn include/python$(LDVERSION) $(DESTDIR)$(prefix)/Headers
|
|
- sed 's/%VERSION%/'"`$(RUNSHARED) ./$(BUILDPYTHON) -c 'import platform; print(platform.python_version())'`"'/g' < $(RESSRCDIR)/Info.plist > $(DESTDIR)$(prefix)/Resources/Info.plist
|
|
+ sed 's/%VERSION%/'"`$(RUNSHARED) $(HOSTPYTHON) -c 'import platform; print(platform.python_version())'`"'/g' < $(RESSRCDIR)/Info.plist > $(DESTDIR)$(prefix)/Resources/Info.plist
|
|
$(LN) -fsn $(VERSION) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Versions/Current
|
|
$(LN) -fsn Versions/Current/$(PYTHONFRAMEWORK) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/$(PYTHONFRAMEWORK)
|
|
$(LN) -fsn Versions/Current/Headers $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Headers
|
|
@@ -1547,7 +1549,7 @@ config.status: $(srcdir)/configure
|
|
|
|
# Run reindent on the library
|
|
reindent:
|
|
- ./$(BUILDPYTHON) $(srcdir)/Tools/scripts/reindent.py -r $(srcdir)/Lib
|
|
+ $(HOSTPYTHON) $(srcdir)/Tools/scripts/reindent.py -r $(srcdir)/Lib
|
|
|
|
# Rerun configure with the same options as it was run last time,
|
|
# provided the config.status script exists
|
|
@@ -1683,7 +1685,7 @@ funny:
|
|
|
|
# Perform some verification checks on any modified files.
|
|
patchcheck: all
|
|
- $(RUNSHARED) ./$(BUILDPYTHON) $(srcdir)/Tools/scripts/patchcheck.py
|
|
+ $(RUNSHARED) ./$(HOSTPYTHON) $(srcdir)/Tools/scripts/patchcheck.py
|
|
|
|
# Dependencies
|
|
|