98 lines
4.5 KiB
Diff
Executable File
98 lines
4.5 KiB
Diff
Executable File
We need to ensure our host tools get run during build, not the freshly
|
|
built cross-tools (this will not work), so we introduce HOSTPYTHON and HOSTPGEN.
|
|
|
|
Upstream-Status: Inappropriate [embedded specific]
|
|
|
|
Signed-off-by: Michael 'Mickey' Lauer <mickey@vanille-media.de>
|
|
Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
|
|
|
|
Rebased for python-2.7.9
|
|
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
|
|
|
|
Index: Python-2.7.12/Makefile.pre.in
|
|
===================================================================
|
|
--- Python-2.7.12.orig/Makefile.pre.in
|
|
+++ Python-2.7.12/Makefile.pre.in
|
|
@@ -246,6 +246,7 @@ LIBFFI_INCLUDEDIR= @LIBFFI_INCLUDEDIR@
|
|
##########################################################################
|
|
# Parser
|
|
PGEN= Parser/pgen$(EXE)
|
|
+HOSTPGEN= $(PGEN)$(EXE)
|
|
|
|
PSRCS= \
|
|
Parser/acceler.c \
|
|
@@ -513,7 +514,7 @@ $(BUILDPYTHON): Modules/python.o $(LIBRA
|
|
$(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
|
|
|
|
platform: $(BUILDPYTHON) pybuilddir.txt
|
|
- $(RUNSHARED) $(PYTHON_FOR_BUILD) -c 'import sys ; from sysconfig import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
|
|
+ $(RUNSHARED) $(PYTHON_FOR_BUILD) -c 'import sys ; from distutils.util import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
|
|
|
|
# Create build directory and generate the sysconfig build-time data there.
|
|
# pybuilddir.txt contains the name of the build dir and is used for
|
|
@@ -684,7 +685,7 @@ $(GRAMMAR_H): $(GRAMMAR_INPUT) $(PGEN)
|
|
@$(MKDIR_P) Include
|
|
# Avoid copying the file onto itself for an in-tree build
|
|
if test "$(cross_compiling)" != "yes"; then \
|
|
- $(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C); \
|
|
+ $(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C); \
|
|
else \
|
|
cp $(srcdir)/Include/graminit.h $(GRAMMAR_H).tmp; \
|
|
mv $(GRAMMAR_H).tmp $(GRAMMAR_H); \
|
|
@@ -1133,27 +1134,27 @@ libinstall: build_all $(srcdir)/Lib/$(PL
|
|
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
|
|
fi
|
|
PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- $(PYTHON_FOR_BUILD) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
+ $(HOSTPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
-d $(LIBDEST) -f \
|
|
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
|
|
$(DESTDIR)$(LIBDEST)
|
|
PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- $(PYTHON_FOR_BUILD) -Wi -tt -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
+ $(HOSTPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
-d $(LIBDEST) -f \
|
|
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
|
|
$(DESTDIR)$(LIBDEST)
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- $(PYTHON_FOR_BUILD) -Wi -t $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
+ $(HOSTPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
-d $(LIBDEST)/site-packages -f \
|
|
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- $(PYTHON_FOR_BUILD) -Wi -t -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
+ $(HOSTPYTHON) -Wi -tt $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
-d $(LIBDEST)/site-packages -f \
|
|
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- $(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
|
|
+ $(HOSTPYTHON) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- $(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
|
|
+ $(HOSTPYTHON) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
|
|
|
|
# Create the PLATDIR source directory, if one wasn't distributed..
|
|
$(srcdir)/Lib/$(PLATDIR):
|
|
Index: Python-2.7.12/setup.py
|
|
===================================================================
|
|
--- Python-2.7.12.orig/setup.py
|
|
+++ Python-2.7.12/setup.py
|
|
@@ -350,6 +350,7 @@ class PyBuildExt(build_ext):
|
|
self.failed.append(ext.name)
|
|
self.announce('*** WARNING: renaming "%s" since importing it'
|
|
' failed: %s' % (ext.name, why), level=3)
|
|
+ return
|
|
assert not self.inplace
|
|
basename, tail = os.path.splitext(ext_filename)
|
|
newname = basename + "_failed" + tail
|
|
@@ -574,6 +575,9 @@ class PyBuildExt(build_ext):
|
|
|
|
# XXX Omitted modules: gl, pure, dl, SGI-specific modules
|
|
|
|
+ lib_dirs = [ os.getenv("STAGING_LIBDIR"), os.getenv("STAGING_BASELIBDIR") ]
|
|
+ inc_dirs = [ os.getenv("STAGING_INCDIR") ]
|
|
+
|
|
#
|
|
# The following modules are all pretty straightforward, and compile
|
|
# on pretty much any POSIXish platform.
|