39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
From 9182bc2dc676858a823c477d8f45a578b8c4f69f Mon Sep 17 00:00:00 2001
|
|
From: Hongxu Jia <hongxu.jia@windriver.com>
|
|
Date: Sun, 12 Jun 2016 04:44:29 -0400
|
|
Subject: [PATCH] tests/Makefile.am: fix undefined reference to
|
|
`pthread_create'
|
|
|
|
Add missing '-lpthread' to CFLAGS
|
|
|
|
Upstream-Status: Pending
|
|
|
|
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
|
|
|
|
---
|
|
tests/Makefile.am | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/tests/Makefile.am b/tests/Makefile.am
|
|
index e6953fd..f47e1d3 100644
|
|
--- a/tests/Makefile.am
|
|
+++ b/tests/Makefile.am
|
|
@@ -76,7 +76,7 @@ t_mpi_bit_LDADD = $(standard_ldadd) @LDADD_FOR_TESTS_KLUDGE@
|
|
t_secmem_LDADD = $(standard_ldadd) @LDADD_FOR_TESTS_KLUDGE@
|
|
testapi_LDADD = $(standard_ldadd) @LDADD_FOR_TESTS_KLUDGE@
|
|
t_lock_LDADD = $(standard_ldadd) $(GPG_ERROR_MT_LIBS) @LDADD_FOR_TESTS_KLUDGE@
|
|
-t_lock_CFLAGS = $(GPG_ERROR_MT_CFLAGS)
|
|
+t_lock_CFLAGS = $(GPG_ERROR_MT_CFLAGS) -lpthread
|
|
testdrv_LDADD = $(LDADD_FOR_TESTS_KLUDGE)
|
|
|
|
# Build a version of the test driver for the build platform.
|
|
@@ -95,7 +95,7 @@ else
|
|
xtestsuite_libs = ../src/.libs/libgcrypt.so*
|
|
xtestsuite_driver = testdrv
|
|
t_kdf_LDADD = $(standard_ldadd) $(GPG_ERROR_MT_LIBS) @LDADD_FOR_TESTS_KLUDGE@
|
|
-t_kdf_CFLAGS = $(GPG_ERROR_MT_CFLAGS)
|
|
+t_kdf_CFLAGS = $(GPG_ERROR_MT_CFLAGS) -lpthread
|
|
endif
|
|
|
|
# xcheck uses our new testdrv instead of the automake test runner.
|