41 lines
1.3 KiB
BlitzBasic
41 lines
1.3 KiB
BlitzBasic
DESCRIPTION="Application library for the Xfce desktop environment"
|
|
SECTION = "x11"
|
|
LICENSE = "GPLv2"
|
|
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
|
|
DEPENDS = "gtk+ libxfce4util libxfce4ui virtual/libx11 liburi-perl-native cairo"
|
|
DEPENDS_class-native = "glib-2.0-native xfce4-dev-tools-native intltool-native"
|
|
|
|
inherit xfce pythonnative perlnative gtk-doc distro_features_check
|
|
|
|
REQUIRED_DISTRO_FEATURES = "x11"
|
|
REQUIRED_DISTRO_FEATURES_class-native = ""
|
|
|
|
# SRC_URI must follow inherited one
|
|
SRC_URI += " \
|
|
file://exo-no-tests-0.8.patch \
|
|
file://configure.patch \
|
|
file://0001-Probable-fix-for-Thunar-detailed-view-Xfce-12916.patch \
|
|
"
|
|
|
|
SRC_URI_append_class-native = " \
|
|
file://reduce-build-to-exo-csource-only.patch \
|
|
"
|
|
|
|
SRC_URI[md5sum] = "866292556586facb034191aa66431697"
|
|
SRC_URI[sha256sum] = "c70c47f690284a5cb4f507dd89088efbdd8123506f924e33a5f97aab74eb97d4"
|
|
|
|
PACKAGES =+ "exo-csource"
|
|
|
|
# Note: python bindings did not work in oe-dev and are about to be moved to
|
|
# pyxfce see http://comments.gmane.org/gmane.comp.desktop.xfce.devel.version4/19560
|
|
FILES_${PN} += "${datadir}/xfce4/ \
|
|
${libdir}/xfce4/exo-1 \
|
|
"
|
|
|
|
FILES_${PN}-dbg += "${libdir}/gio/modules/.debug \
|
|
"
|
|
|
|
FILES_exo-csource += "${bindir}/exo-csource"
|
|
|
|
BBCLASSEXTEND = "native"
|