37 lines
1.3 KiB
BlitzBasic
37 lines
1.3 KiB
BlitzBasic
SUMMARY = "Web-based MySQL administration interface"
|
|
HOMEPAGE = "http://www.phpmyadmin.net"
|
|
# Main code is GPLv2, libraries/tcpdf is under LGPLv3, js/jquery is under MIT
|
|
LICENSE = "GPLv2 & LGPLv3 & MIT"
|
|
LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
|
|
file://libraries/tcpdf/LICENSE.TXT;md5=5c87b66a5358ebcc495b03e0afcd342c"
|
|
|
|
SRC_URI = "https://files.phpmyadmin.net/phpMyAdmin/${PV}/phpMyAdmin-${PV}-all-languages.tar.xz \
|
|
file://apache.conf \
|
|
"
|
|
|
|
SRC_URI[md5sum] = "53c7a6a577d10de04a5dd21a05018542"
|
|
SRC_URI[sha256sum] = "943bad38a95f21bb015bdb78c9c067e0ea7510c1b35d4b8e757cb89c413e3bac"
|
|
|
|
S = "${WORKDIR}/phpMyAdmin-${PV}-all-languages"
|
|
|
|
inherit allarch
|
|
|
|
do_install() {
|
|
install -d ${D}${datadir}/${BPN}
|
|
cp -R --no-dereference --preserve=mode,links -v * ${D}${datadir}/${BPN}
|
|
chown -R root:root ${D}${datadir}/${BPN}
|
|
# Don't install patches to target
|
|
rm -rf ${D}${datadir}/${BPN}/patches
|
|
|
|
install -d ${D}${sysconfdir}/apache2/conf.d
|
|
install -m 0644 ${WORKDIR}/apache.conf ${D}${sysconfdir}/apache2/conf.d/phpmyadmin.conf
|
|
|
|
# Remove a few scripts that explicitly require bash (!)
|
|
rm -f ${D}${datadir}/phpmyadmin/libraries/transformations/*.sh
|
|
}
|
|
|
|
FILES_${PN} = "${datadir}/${BPN} \
|
|
${sysconfdir}/apache2/conf.d"
|
|
|
|
RDEPENDS_${PN} += "bash"
|