avs_mtk_voice/meta/meta-openembedded/meta-oe/recipes-benchmark/memtester/memtester_4.3.0.bb

26 lines
777 B
BlitzBasic

SUMMARY = "Utility to test for faulty memory subsystem"
HOMEPAGE = "http://pyropus.ca/software/memtester/"
SECTION = "console/utils"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
SRC_URI = "http://pyropus.ca/software/memtester/old-versions/${BP}.tar.gz"
SRC_URI += "file://Makefile.patch"
SRC_URI[md5sum] = "598f41b7308e1f736164bca3ab84ddbe"
SRC_URI[sha256sum] = "f9dfe2fd737c38fad6535bbab327da9a21f7ce4ea6f18c7b3339adef6bf5fd88"
do_compile () {
echo '${CC} ${CFLAGS} -DPOSIX -c' > conf-cc
echo '${CC} ${LDFLAGS}' > conf-ld
oe_runmake
}
do_install () {
install -d ${D}${bindir}
install -d ${D}${mandir}/man8
install -m 0755 memtester ${D}${bindir}/
install -m 0755 memtester.8 ${D}${mandir}/man8/
}