30 lines
861 B
BlitzBasic
30 lines
861 B
BlitzBasic
DESCRIPTION = "libcoap"
|
|
LICENSE = "GPLv2"
|
|
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
|
|
|
|
#APPS_SRC = "${TOPDIR}/../src/apps/aud-base/library/mdns"
|
|
#APPS_SRC = "${TOPDIR}/../src/apps/aud-base/libev-4.15"
|
|
|
|
SRC_URI = "file://libcoap-${PV}.zip"
|
|
SRC_URI[md5sum] = "e39d8c407739a03f7a441fcc3d9bc57e"
|
|
SRC_URI[sha256sum] = "4caf73446a4994a0571afaf5e60a62a749bda92a29e9407174614733e984c238"
|
|
|
|
#inherit autotools pkgconfig workonsrc
|
|
inherit autotools pkgconfig
|
|
|
|
PACKAGECONFIG ??= "disable-documentation disable-examples"
|
|
|
|
PACKAGECONFIG[disable-documentation] = "--disable-documentation"
|
|
PACKAGECONFIG[disable-examples] = "--disable-examples"
|
|
|
|
#WORKONSRC = "${APPS_SRC}"
|
|
|
|
do_configure_prepend() {
|
|
sh ${S}/autogen.sh
|
|
}
|
|
|
|
FILES_${PN}+="${libdir}"
|
|
FILES_${PN}-dev = "${includedir} ${libdir}/libcoap*.so"
|
|
INSANE_SKIP_${PN} += "already-stripped"
|
|
|