24 lines
690 B
BlitzBasic
Executable File
24 lines
690 B
BlitzBasic
Executable File
SUMMARY = "C bindings for apps which will manipulate JSON data"
|
|
DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
|
|
HOMEPAGE = "https://github.com/json-c/json-c/wiki"
|
|
LICENSE = "MIT"
|
|
LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
|
|
|
|
SRCREV = "6460446aa60d8d27338c21c49ce061ecd87f7466"
|
|
SRC_URI = " \
|
|
git://github.com/json-c/json-c.git \
|
|
"
|
|
|
|
S = "${WORKDIR}/git"
|
|
|
|
RPROVIDES_${PN} = "libjson"
|
|
|
|
inherit autotools
|
|
|
|
do_configure_prepend() {
|
|
# Clean up autoconf cruft that should not be in the tarball
|
|
rm -f ${S}/config.status
|
|
}
|
|
|
|
BBCLASSEXTEND = "native nativesdk"
|