avs_mtk_voice/meta/meta-mediatek-aud/recipes-support/jemalloc/jemalloc_5.3.0.bb

23 lines
728 B
BlitzBasic

# Copyright (C) 2021 Mingli Yu <mingli.yu@windriver.com>
# Released under the MIT license (see COPYING.MIT for the terms)
SUMMARY = "General-purpose scalable concurrent malloc implementation"
DESCRIPTION = "jemalloc is a general purpose malloc(3) implementation that emphasizes \
fragmentation avoidance and scalable concurrency support."
HOMEPAGE = "https://github.com/jemalloc/jemalloc"
LICENSE = "BSD-2-Clause"
SECTION = "libs"
LIC_FILES_CHKSUM = "file://COPYING;md5=ea061f8731d5e6a5761dfad951ef5f5f"
SRC_URI = "git://github.com/jemalloc/jemalloc.git;branch=master;protocol=https "
SRCREV = "54eaed1d8b56b1aa528be3bdd1877e59c56fa90c"
S = "${WORKDIR}/git"
inherit autotools
EXTRA_AUTORECONF += "--exclude=autoheader"