DESCRIPTION = "debuglog"
LICENSE = "MediaTekProprietary"
LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"

APPS_SRC = "${TOPDIR}/../src/apps/aud-base/debuglog"

inherit workonsrc systemd

WORKONSRC = "${APPS_SRC}"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "debuglog.service"
FILES_${PN} += "${systemd_unitdir}/system/debuglog.service"


do_install() {
	install -d ${D}/${bindir}
	install -d ${D}${systemd_unitdir}/system
	install -m 755 ${S}/debuglog.sh ${D}/${bindir}
	install -m 755 ${S}/debuglog.service ${D}${systemd_unitdir}/system
}

FILES_${PN} += ""
INSANE_SKIP_${PN} += "already-stripped"
FILES_${PN}-dev = ""